因为php的dos漏洞,不得不升级php,

搞了好多版本都不支持ioncube_loaders,一直以为kangle限制了,其实是版本没对应上

都是来自第三方的 整理一下。

kangle自带的php5.2.17应该是线程安全版,

对应的补丁版本用这个 http://www.upupw.net/Expand/n104.html

然后这个是vc6编译的ioncube_loaders就要用 VC6的版本

http://downloads3.ioncube.com/loader_downloads/ioncube_loaders_win_vc6_x86.zip

这个对应起来才能加载ioncube_loaders。

问题就是php编译有 VC6 ,VC9,VC11的区别.

同样php5.3.29, ioncube_loaders版本对应不上也加载不了,http://www.ioncube.com/loaders.php 从这里找php编译时对应的的版本.对应vc9或者vc11,然后还有ts和nts。

其实我也不懂为什么php5.2.17用的ts版本,php5.3.29却用的nts版。

, ,
Trackback

no comment 至今

添加评论